Migrate to AdoptOpenJDK API v3

Description

The v3 API will be stable soon and we need to start using it as v2 is deprecated.

https://api.adoptopenjdk.net/swagger-ui/#/

https://maven.apache.org/enforcer/enforcer-rules/versionRanges.html

Assignee

Unassigned

Reporter

Brad Wood

Labels

None

Affects versions

None

Fix versions

Priority

Major
Configure