Rename WireBox provider get() to $get() to avoid conflicts with provided classes

Description

The de facto usage of providers in ColdBox has become that people use the onMissingMethod proxy in providers so the provider itself is a seamless wrapper around the provided object.

It has become more and more common that we run into actual "get()" methods on the provided models that conflict with the actual get() method on the provider CFC. In order to retain the "Provider Design Pattern" let's rename the built-in get() to be $get() so it isn't as likely to conflict with the onMissingMethod proxy.

This will be a breaking change so it needs to happen in ColdBox 6.

Assignee

Luis Majano

Reporter

Brad Wood

Labels

Fix versions

Affects versions

Priority

Major
Configure