We're updating the issue view to help you get more done. 

Add tabbed autocomplete for required parameter prompt

Description

This emerged from a Slack discussion with . Here's a brief transcription of the relevant portions - the attachment is a screenshot of the thread.

I am writing a commandBox module with a command. One of the command arguments is required. I have a UDF that provides the possible values for the argument. If I enter the command and argument, I’m able to use the autocomplete. However, if I only enter the command, when I’m prompted for the required argument, the autocomplete options are not available.

The module in question: https://www.forgebox.io/view/api-wrapper-template

If I enter apiWrapper scaffold apiAuthentication= then I am able to use the autocomplete options from the UDF

When I enter apiwrapper scaffold-wizard, which prompts for the apiAuthentication argument as required, my tab completions don’t get listed

Status

Assignee

Unassigned

Reporter

Matthew Clemente

Labels

Priority

Minor