The discrepancy here is valuePairTranslator vs valuePairTranslation.
The actual method in the router is valuePairTranslator.
I'd put in a PR for this, but I'm not sure which name is intended.
I did put in a PR for the docs to match the actual method, before I realized that they might have been right and the method might be wrong.
I say let’s go with translator and I would love that PR?